Uploaded image for project: 'Mule'
  1. Mule
  2. MULE-16274

HTTP service client cannot do gzip response decompression

    Details

    • Severity:
      S3
    • Bug Boosted:
      No
    • Defect Source:
      Dev Bug
    • Story Points:
      4
    • Sprint:
      Mule 4 - Wookie 01/02
    • Severity Label:
      S3

      Description

      Attaching a request to a Web Service using only the HTTP connector in which im getting a weird behaviour with the response that is not happening with other HTTP clients (Insomia, Postman and Soap UI).

      See attached application to reproduce.


      The  performing request is the following

      POST /fscmService/ErpIntegrationService HTTP/1.1
      Host: edvo-dev1.fin.em2.oraclecloud.com:443
      Authorization: Basic UFJDX0lOVEVHUkFUSU9OOldlbGNvbWUx
      Content-Type: text/xml
      Content-Length: 786
      
      %%envelope-content%%
      

      The received response from the Http Connector is raw data in some unknown format, but the expected response content (which other client returns) is something like this

      <?xml version="1.0" encoding="UTF-8" ?>
      <env:Envelope
        xmlns:env="http://schemas.xmlsoap.org/soap/envelope/">
        <env:Header/>
        <env:Body>
          <env:Fault
            xmlns:ns0="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd">
            <faultcode>ns0:InvalidSecurityToken</faultcode>
            <faultstring>InvalidSecurityToken : The security token is not valid.</faultstring>
            <faultactor></faultactor>
          </env:Fault>
        </env:Body>
      </env:Envelope>
      

      NOTE: PostMan returns the SAME content as a Mime Part

      ------=_Part_101051_202779406.1545948561780
      Content-Type: application/xop+xml;charset=UTF-8;type="text/xml"
      Content-Transfer-Encoding: 8bit
      Content-ID: <b53505a4-54e6-4012-9789-962e761e9392>
      
      <?xml version="1.0" encoding="UTF-8" ?>
      <env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"><env:Header/><env:Body><env:Fault xmlns:ns0="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd"><faultcode>ns0:InvalidSecurityToken</faultcode><faultstring>InvalidSecurityToken : The security token is not valid.</faultstring><faultactor></faultactor></env:Fault></env:Body></env:Envelope>
      ------=_Part_101051_202779406.1545948561780--
      

        Attachments

          Activity

            People

            • Assignee:
              afelisatti Ana Felisatti
              Reporter:
              juan.desimoni Juan Desimoni
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: