Mule
  1. Mule
  2. MULE-2410

Problem while embedding Mule in tomcat

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 1.4.3
    • Fix Version/s: 1.4.4
    • Component/s: Build: (other)
    • Labels:
      None
    • Environment:

      Mule1.4.3
      Tomcat 5.0
      JDK 1.5

    • User impact:
      High
    • Configuration:
      Hide

      <web-app>

      <context-param>
      <param-name>org.mule.config</param-name>
      <param-value>/WEB-INF/axis-message-service.xml</param-value>
      </context-param>

      <listener>
      <listener-class>org.mule.config.builders.MuleXmlBuilderContextListener</listener-class>
      </listener>
      ....
      .....
      </web-app>

      Show
      <web-app> <context-param> <param-name>org.mule.config</param-name> <param-value>/WEB-INF/axis-message-service.xml</param-value> </context-param> <listener> <listener-class>org.mule.config.builders.MuleXmlBuilderContextListener</listener-class> </listener> .... ..... </web-app>
    • Log Output:
      Hide
      2007-09-20 12:50:51,480 DEBUG (MuleDtdResolver.java:<init>:86) [main] | Created Mule Dtd Resolver: dtd=mule-configuration.dtd, xsl=null, delegate resolver=null,
      2007-09-20 12:50:52,465 DEBUG (MuleXmlConfigurationBuilder.java:configure:200) [main] | There is/are 1 configuration resource(s): {/WEB-INF/axis-message-service.xml}
      2007-09-20 12:50:52,465 DEBUG (WebappMuleXmlConfigurationBuilder.java:loadResource:49) [main] | Searching for resource D:\WEB-INF\axis-message-service.xml in Servlet Context.
      2007-09-20 12:50:52,465 DEBUG (WebappMuleXmlConfigurationBuilder.java:loadResource:53) [main] | Resource D:\WEB-INF\axis-message-service.xml not found in Servlet Context, loading from classpath
      2007-09-20 12:50:52,480 DEBUG (IOUtils.java:getResourceAsUrl:160) [main] | Unable to load resource from the file system: D:\WEB-INF\axis-message-service.xml
      2007-09-20 12:50:52,496 DEBUG (IOUtils.java:getResourceAsUrl:184) [main] | Unable to load resource from the classpath
      2007-09-20 12:50:52,496 DEBUG (IOUtils.java:getResourceAsStream:101) [main] | Unable to load resource as a URL: /WEB-INF/axis-message-service.xml
      2007-09-20 12:50:52,511 DEBUG (MessageFactory.java:getBundle:197) [main] | Loading resource bundle: META-INF.services.org.mule.i18n.core-messages for locale en_US
      Show
      2007-09-20 12:50:51,480 DEBUG (MuleDtdResolver.java:<init>:86) [main] | Created Mule Dtd Resolver: dtd=mule-configuration.dtd, xsl=null, delegate resolver=null, 2007-09-20 12:50:52,465 DEBUG (MuleXmlConfigurationBuilder.java:configure:200) [main] | There is/are 1 configuration resource(s): {/WEB-INF/axis-message-service.xml} 2007-09-20 12:50:52,465 DEBUG (WebappMuleXmlConfigurationBuilder.java:loadResource:49) [main] | Searching for resource D:\WEB-INF\axis-message-service.xml in Servlet Context. 2007-09-20 12:50:52,465 DEBUG (WebappMuleXmlConfigurationBuilder.java:loadResource:53) [main] | Resource D:\WEB-INF\axis-message-service.xml not found in Servlet Context, loading from classpath 2007-09-20 12:50:52,480 DEBUG (IOUtils.java:getResourceAsUrl:160) [main] | Unable to load resource from the file system: D:\WEB-INF\axis-message-service.xml 2007-09-20 12:50:52,496 DEBUG (IOUtils.java:getResourceAsUrl:184) [main] | Unable to load resource from the classpath 2007-09-20 12:50:52,496 DEBUG (IOUtils.java:getResourceAsStream:101) [main] | Unable to load resource as a URL: /WEB-INF/axis-message-service.xml 2007-09-20 12:50:52,511 DEBUG (MessageFactory.java:getBundle:197) [main] | Loading resource bundle: META-INF.services.org.mule.i18n.core-messages for locale en_US
    • Similar Issues:
      MULE-6705NoSuchMethodError in Tomcat embedded MULE when executing http:set-cookie
      MULE-6800Thread leak on Mule redeployments for embedded
      MULE-8773Tomcat 8 after final release no longer works with cookie processing
      MULE-1205Mule thread count & memory problem while app server starting
      MULE-5208problem using <mule-send> in jbpm 4.4 to call mule 3.0.1
      MULE-4180Webapp example REST support is broken on embedded Tomcat
      MULE-4164org.mule.providers.file.FileConnector(File name is not fetching at first time while restartging web server -- tomcat)
      MULE-5707Jar conflicts while deploying bookstore example on JBoss and Tomcat
      MULE-352Problem with LOBs in JDBC Provider
      MULE-7789Update mule-transports-http to tomcat 6+

      Description

      While embedding the mule in tomcat, it expects absolute path of mule configuration file on web.xml; when you give Relative path it failed to load that resource.

      Note: This relative path configuration was working fine with Mule1.3.3.

        Issue Links

          Activity

            People

            • Assignee:
              Andrew Perepelytsya
              Reporter:
              Prem vmvrajan
            • Votes:
              1 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development