Mule
  1. Mule
  2. MULE-4186

Bookstore admin Add Book doesn't have any validation, fails with 'File not found error'

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: 2.2
    • Component/s: Examples / Tutorials
    • Labels:
      None
    • Environment:

      Firefox 3, Win

    • User impact:
      High
    • Log Output:
      Caused by: org.mule.api.endpoint.MalformedEndpointException: The endpoint "catalog" is malformed and cannot be parsed. If this is the name of a global endpoint, check the name is correct, that the en
      dpoint exists, and that you are using the correct configuration (eg the "ref" attribute). Note that names on inbound and outbound endpoints cannot be used to send or receive messages; use a named glo
      bal endpoint instead.
              at org.mule.endpoint.MuleEndpointURI.<init>(MuleEndpointURI.java:137)
              at org.mule.endpoint.URIBuilder.getEndpoint(URIBuilder.java:173)
              ... 21 more
      [02-19 12:09:47] ERROR MuleRESTReceiverServlet [http-8081-1]: message: Bad endpoint configuration
      java.lang.IllegalStateException: Bad endpoint configuration
              at org.mule.endpoint.URIBuilder.getEndpoint(URIBuilder.java:178)
              at org.mule.endpoint.AbstractEndpointBuilder.getProperties(AbstractEndpointBuilder.java:265)
              at org.mule.endpoint.AbstractEndpointBuilder.doBuildInboundEndpoint(AbstractEndpointBuilder.java:129)
              at org.mule.endpoint.AbstractEndpointBuilder.buildInboundEndpoint(AbstractEndpointBuilder.java:88)
              at org.mule.endpoint.DefaultEndpointFactory.getInboundEndpoint(DefaultEndpointFactory.java:80)
              at org.mule.endpoint.DefaultEndpointFactory.getInboundEndpoint(DefaultEndpointFactory.java:48)
              at org.mule.transport.servlet.MuleRESTReceiverServlet.getEndpointForURI(MuleRESTReceiverServlet.java:188)
              at org.mule.transport.servlet.MuleRESTReceiverServlet.doGet(MuleRESTReceiverServlet.java:58)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
              at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
              at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
              at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
              at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
              at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
              at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
              at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
              at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
              at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
              at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
              at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
              at java.lang.Thread.run(Thread.java:595)
      Caused by: org.mule.api.endpoint.MalformedEndpointException: The endpoint "catalog" is malformed and cannot be parsed. If this is the name of a global endpoint, check the name is correct, that the en
      dpoint exists, and that you are using the correct configuration (eg the "ref" attribute). Note that names on inbound and outbound endpoints cannot be used to send or receive messages; use a named glo
      bal endpoint instead.
              at org.mule.endpoint.MuleEndpointURI.<init>(MuleEndpointURI.java:137)
              at org.mule.endpoint.URIBuilder.getEndpoint(URIBuilder.java:173)
              ... 21 more
      [02-19 12:10:06] ERROR MuleRESTReceiverServlet [http-8081-1]: message: Bad endpoint configuration
      java.lang.IllegalStateException: Bad endpoint configuration
              at org.mule.endpoint.URIBuilder.getEndpoint(URIBuilder.java:178)
              at org.mule.endpoint.AbstractEndpointBuilder.getProperties(AbstractEndpointBuilder.java:265)
              at org.mule.endpoint.AbstractEndpointBuilder.doBuildInboundEndpoint(AbstractEndpointBuilder.java:129)
              at org.mule.endpoint.AbstractEndpointBuilder.buildInboundEndpoint(AbstractEndpointBuilder.java:88)
              at org.mule.endpoint.DefaultEndpointFactory.getInboundEndpoint(DefaultEndpointFactory.java:80)
              at org.mule.endpoint.DefaultEndpointFactory.getInboundEndpoint(DefaultEndpointFactory.java:48)
              at org.mule.transport.servlet.MuleRESTReceiverServlet.getEndpointForURI(MuleRESTReceiverServlet.java:188)
              at org.mule.transport.servlet.MuleRESTReceiverServlet.doGet(MuleRESTReceiverServlet.java:58)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
              at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
              at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
              at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
              at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
              at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
              at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
              at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
              at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
              at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
              at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
              at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
              at java.lang.Thread.run(Thread.java:595)
      Caused by: org.mule.api.endpoint.MalformedEndpointException: The endpoint "catalog" is malformed and cannot be parsed. If this is the name of a global endpoint, check the name is correct, that the en
      dpoint exists, and that you are using the correct configuration (eg the "ref" attribute). Note that names on inbound and outbound endpoints cannot be used to send or receive messages; use a named glo
      bal endpoint instead.
              at org.mule.endpoint.MuleEndpointURI.<init>(MuleEndpointURI.java:137)
              at org.mule.endpoint.URIBuilder.getEndpoint(URIBuilder.java:173)
              ... 21 more


      Show
      Caused by: org.mule.api.endpoint.MalformedEndpointException: The endpoint "catalog" is malformed and cannot be parsed. If this is the name of a global endpoint, check the name is correct, that the en dpoint exists, and that you are using the correct configuration (eg the "ref" attribute). Note that names on inbound and outbound endpoints cannot be used to send or receive messages; use a named glo bal endpoint instead.         at org.mule.endpoint.MuleEndpointURI.<init>(MuleEndpointURI.java:137)         at org.mule.endpoint.URIBuilder.getEndpoint(URIBuilder.java:173)         ... 21 more [02-19 12:09:47] ERROR MuleRESTReceiverServlet [http-8081-1]: message: Bad endpoint configuration java.lang.IllegalStateException: Bad endpoint configuration         at org.mule.endpoint.URIBuilder.getEndpoint(URIBuilder.java:178)         at org.mule.endpoint.AbstractEndpointBuilder.getProperties(AbstractEndpointBuilder.java:265)         at org.mule.endpoint.AbstractEndpointBuilder.doBuildInboundEndpoint(AbstractEndpointBuilder.java:129)         at org.mule.endpoint.AbstractEndpointBuilder.buildInboundEndpoint(AbstractEndpointBuilder.java:88)         at org.mule.endpoint.DefaultEndpointFactory.getInboundEndpoint(DefaultEndpointFactory.java:80)         at org.mule.endpoint.DefaultEndpointFactory.getInboundEndpoint(DefaultEndpointFactory.java:48)         at org.mule.transport.servlet.MuleRESTReceiverServlet.getEndpointForURI(MuleRESTReceiverServlet.java:188)         at org.mule.transport.servlet.MuleRESTReceiverServlet.doGet(MuleRESTReceiverServlet.java:58)         at javax.servlet.http.HttpServlet.service(HttpServlet.java:690)         at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)         at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)         at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)         at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)         at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)         at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)         at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)         at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)         at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)         at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)         at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)         at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)         at java.lang.Thread.run(Thread.java:595) Caused by: org.mule.api.endpoint.MalformedEndpointException: The endpoint "catalog" is malformed and cannot be parsed. If this is the name of a global endpoint, check the name is correct, that the en dpoint exists, and that you are using the correct configuration (eg the "ref" attribute). Note that names on inbound and outbound endpoints cannot be used to send or receive messages; use a named glo bal endpoint instead.         at org.mule.endpoint.MuleEndpointURI.<init>(MuleEndpointURI.java:137)         at org.mule.endpoint.URIBuilder.getEndpoint(URIBuilder.java:173)         ... 21 more [02-19 12:10:06] ERROR MuleRESTReceiverServlet [http-8081-1]: message: Bad endpoint configuration java.lang.IllegalStateException: Bad endpoint configuration         at org.mule.endpoint.URIBuilder.getEndpoint(URIBuilder.java:178)         at org.mule.endpoint.AbstractEndpointBuilder.getProperties(AbstractEndpointBuilder.java:265)         at org.mule.endpoint.AbstractEndpointBuilder.doBuildInboundEndpoint(AbstractEndpointBuilder.java:129)         at org.mule.endpoint.AbstractEndpointBuilder.buildInboundEndpoint(AbstractEndpointBuilder.java:88)         at org.mule.endpoint.DefaultEndpointFactory.getInboundEndpoint(DefaultEndpointFactory.java:80)         at org.mule.endpoint.DefaultEndpointFactory.getInboundEndpoint(DefaultEndpointFactory.java:48)         at org.mule.transport.servlet.MuleRESTReceiverServlet.getEndpointForURI(MuleRESTReceiverServlet.java:188)         at org.mule.transport.servlet.MuleRESTReceiverServlet.doGet(MuleRESTReceiverServlet.java:58)         at javax.servlet.http.HttpServlet.service(HttpServlet.java:690)         at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)         at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)         at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)         at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)         at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)         at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)         at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)         at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)         at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)         at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)         at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)         at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)         at java.lang.Thread.run(Thread.java:595) Caused by: org.mule.api.endpoint.MalformedEndpointException: The endpoint "catalog" is malformed and cannot be parsed. If this is the name of a global endpoint, check the name is correct, that the en dpoint exists, and that you are using the correct configuration (eg the "ref" attribute). Note that names on inbound and outbound endpoints cannot be used to send or receive messages; use a named glo bal endpoint instead.         at org.mule.endpoint.MuleEndpointURI.<init>(MuleEndpointURI.java:137)         at org.mule.endpoint.URIBuilder.getEndpoint(URIBuilder.java:173)         ... 21 more
    • Similar Issues:
      MULE-5777Bookstore example admin war file doesn't work
      MULE-4451admin-web bookstore example error when adding new book
      MULE-4185Bookstore admin example Add Book returns data as form/urlencoded
      MULE-5187error while searching for a book using the bookstore example
      MULE-5427redploying the bookstore example fails
      MULE-6177Bookstore example should run deployed in an app server with MMC
      MULE-4799Bookstore example: fail to list orders
      MULE-5014bookstore example fails on 3.0-RC1
      MULE-4807Bookstore example ordering of books fails due to SoftReference to component in null
      MULE-4438Bookstore example is not working

      Description

      Run bookstore apps
      Go to admin
      Leave all Add Book fields empty
      Click Add Book

      Expected: some validation message, system shouldn't allow submitting this form
      Actual: system submits empty form, backend dumps an error (Missing author field), and the user

      Note: in this scenario, webapp and admin are deployed at different ports (2 mvn tomcat:run commands in 2 shells)

        Issue Links

          Activity

          Andrew Perepelytsya added a comment -

          This issue is gone as a side-effect of another change. Now, such a submission will fail on the backend, though not be presented on the UI. This is a potential improvement, for now closing the issue.

          Ram Biradar added a comment -

          i want the full source code of Bookstore example..thanks in advance..


            People

            • Assignee:
              Andrew Perepelytsya
              Reporter:
              Andrew Perepelytsya
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development