Mule
  1. Mule
  2. MULE-5476

processor expression evaluator doesn't work

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.1.0
    • Fix Version/s: 3.1.x
    • Component/s: Core: Expressions
    • Labels:
      None
    • User impact:
      Medium
    • Configuration:

      <expression-transformer>
      <return-argument expression="flow2use" evaluator="processor"/>
      </expression-transformer>

      Show
      <expression-transformer> <return-argument expression="flow2use" evaluator="processor"/> </expression-transformer>
    • Log Output:
      Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name '(inner bean)': Invocation of init method failed; nested exception is org.mule.api.lifecycle.InitialisationException: An Expression Evaluator for "processor" is not registered with Mule. Make sure you have the the module for this expression type on your classpath. for example, if you are using an xpath expression you need to have the Mule XML module on your classpath.
      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1412)
      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:519)
      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:456)
      at org.springframework.beans.factory.support.BeanDefinitionValueResolver.resolveInnerBean(BeanDefinitionValueResolver.java:270)
      ... 38 more
      Caused by: org.mule.api.lifecycle.InitialisationException: An Expression Evaluator for "processor" is not registered with Mule. Make sure you have the the module for this expression type on your classpath. for example, if you are using an xpath expression you need to have the Mule XML module on your classpath.
      at org.mule.expression.transformers.AbstractExpressionTransformer.initialise(AbstractExpressionTransformer.java:88)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.invokeCustomInitMethod(AbstractAutowireCapableBeanFactory.java:1536)
      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.invokeInitMethods(AbstractAutowireCapableBeanFactory.java:1477)
      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1409)
      ... 41 more
      Caused by: java.lang.IllegalArgumentException: An Expression Evaluator for "processor" is not registered with Mule. Make sure you have the the module for this expression type on your classpath. for example, if you are using an xpath expression you need to have the Mule XML module on your classpath.
      at org.mule.expression.ExpressionConfig.validate(ExpressionConfig.java:99)
      at org.mule.expression.transformers.ExpressionArgument.validate(ExpressionArgument.java:95)
      at org.mule.expression.transformers.AbstractExpressionTransformer.initialise(AbstractExpressionTransformer.java:84)
      ... 48 more
      Show
      Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name '(inner bean)': Invocation of init method failed; nested exception is org.mule.api.lifecycle.InitialisationException: An Expression Evaluator for "processor" is not registered with Mule. Make sure you have the the module for this expression type on your classpath. for example, if you are using an xpath expression you need to have the Mule XML module on your classpath. at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1412) at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:519) at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:456) at org.springframework.beans.factory.support.BeanDefinitionValueResolver.resolveInnerBean(BeanDefinitionValueResolver.java:270) ... 38 more Caused by: org.mule.api.lifecycle.InitialisationException: An Expression Evaluator for "processor" is not registered with Mule. Make sure you have the the module for this expression type on your classpath. for example, if you are using an xpath expression you need to have the Mule XML module on your classpath. at org.mule.expression.transformers.AbstractExpressionTransformer.initialise(AbstractExpressionTransformer.java:88) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597) at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.invokeCustomInitMethod(AbstractAutowireCapableBeanFactory.java:1536) at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.invokeInitMethods(AbstractAutowireCapableBeanFactory.java:1477) at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1409) ... 41 more Caused by: java.lang.IllegalArgumentException: An Expression Evaluator for "processor" is not registered with Mule. Make sure you have the the module for this expression type on your classpath. for example, if you are using an xpath expression you need to have the Mule XML module on your classpath. at org.mule.expression.ExpressionConfig.validate(ExpressionConfig.java:99) at org.mule.expression.transformers.ExpressionArgument.validate(ExpressionArgument.java:95) at org.mule.expression.transformers.AbstractExpressionTransformer.initialise(AbstractExpressionTransformer.java:84) ... 48 more
    • Similar Issues:
      MULE-6345logic 'and' doesn't work in choice expression
      MULE-5736returnSourceIfNull in expression-transformer is not working for scripting evaluators
      MULE-4284SMTP endpoints don't use expression evaluator
      MULE-6411Json Expression Evaluator equals does not work with String literals
      MULE-3143Add a Mule Context expression evaluator
      MULE-5228Variable expression evaluator/enricher for temporary storage during flow.
      MULE-5541Should be possible to have multiple message processors in an enricher without using processor-chain
      MULE-3970Add a String Expression evaluator
      MULE-4529Enable expression evaluation on the address property of a job-endpoint
      MULE-4740Simplify working with Mule Registry when using a groovy expression evaluator

      Description

      The processor expression evaluator mentioned in the online docs doesn't work. It appears the problem is that the xsd requires "processor" but the source for MessageProcessorExpressionEvaluator is registering with the name "process". I've checked and this appears to be in the 3.1.1 source too.

        Activity

        Mike Schilling added a comment -

        I updated the online docs to show the correct name ("process").


          People

          • Assignee:
            Mike Schilling
            Reporter:
            Craig Skinfill
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development